返回列表 发新帖

MySQL常见错误提示及解决方法

2,361.5k 14
开着越野放牛 发表于 2013-6-14 21:00:21|湖北 | 查看全部 阅读模式
130 :文件格式不正确。(还不是很清楚错误的状况)
( Z4 [8 B, l+ e2 e# {( d; q3 U145 :文件无法打开。, a0 N4 U' z, I$ x
1005:创建表失败。% A9 ~$ d$ F5 ^# v8 t9 V
1006:创建数据库失败。
$ l6 X6 m( U% p, [0 k$ N) H1007:数据库已存在,创建数据库失败。
/ N# I: J  A1 o: t$ w3 I, `+ j/ D1008:数据库不存在,删除数据库失败。  }0 Q& ~& d1 I% g" R9 k# b5 W
1009:不能删除数据库文件导致删除数据库失败。
8 {0 J3 N" k; }/ t1010:不能删除数据目录导致删除数据库失败。
! A' O: m. s* T1011:删除数据库文件失败。" ?+ ^, z% a1 O- m* H" T2 |
1012:不能读取系统表中的记录。# ~5 V9 K" X# }& {/ l) L
1016:文件无法打开,使用后台修复或者使用 phpmyadmin 进行修复。
: B7 T5 b* ^$ t" c$ WQuote:# _% k$ Z1 u+ `! K& i( _
开始=>所有程序=>附件=>命令提示符
/ p7 s7 ~/ w" ?/ X: l7 Z( o输入 mysql 所在硬盘盘符
( s: I, |8 ^7 E0 D0 Z  ^1 xcd mysql 所在目录1 F) L8 N1 ?) x3 w
cd bin
! Q# Y5 B. \6 u) }* c6 c4 r' n输入 myisamchk -f D:usr/local/mysql/data/bbs/PW_members.MYI) L: A) A' t4 f& H7 @
ps : D:usr/local/mysql/data/bbs 是你论坛数据库的路径& S2 A5 j$ p5 O# c2 [& ^8 Q' Z( ?( x$ o
-f 根据具体情况选择,一般也可以选择 -r& P) ~; @% ^5 d6 H) {2 \
注意你的 系统C盘或放数据库的硬盘空间是否足够,一般小于 1G 很容易出现错误。
( x" j" m$ i1 q* q; [1 S或用mysqlcheck命令进行修复。具体的方法:利用命令行进入mysql/bin目录,执行" [, ]) k/ |( H8 S4 L# Q; ?- t9 e
mysqlcheck -o -r phpwind -uroot -p5 a6 a; j$ E8 p, \- I4 u
其中phpwind是你数据库的名称,root是你的数据库用户名,然后会提示你输入密码。然后就会修复你的数据库。; d3 `' Z! }' X: X  f" y, G' E( ]
1017:服务器非法关机,导致该文件损坏。
! J( j/ u4 b. F8 o; W4 `1020:记录已被其他用户修改。* }$ I/ S  V% F, V" G# n4 a- J
1021:硬盘剩余空间不足,请加大硬盘可用空间。
1 i+ i! [- l) ?" B! @1022:关键字重复,更改记录失败。
: k) T5 b3 i! C( G9 q/ [3 B1023:关闭时发生错误。
. q3 E4 H4 B/ P1024:读文件错误。
, j$ A6 E6 S$ `. X1025:更改名字时发生错误。
; _' u0 o& A3 Z# Q! U. D, d1026:写文件错误。
% x4 F- H8 y7 T7 y! L( S& N8 N1030:可能是服务器不稳定。(具体原因不是很清楚)
" p3 W1 I1 O8 K1032:记录不存在。
, z; c4 V0 d7 w1036:数据表是只读的,不能对它进行修改。; e5 W# a: m1 Q2 ^% l! g2 i. D
1037:系统内存不足,请重启数据库或重启服务器。8 F4 c6 S4 o& }* f+ d* t
1038:用于排序的内存不足,请增大排序缓冲区。3 i6 O( j; w9 n8 m6 E- O; n
1040:已到达数据库的最大连接数,请加大数据库可用连接数。  T* P. ?: p+ a4 H9 w+ k* c
Quote:" E1 e+ P' ]' e' Q
在my.ini 修改max_connections=100为max_connections=1000或更大,重启mysql
+ J/ L$ g  G; o, a; G1041:系统内存不足。
4 K/ Q+ l5 B2 F2 ~1042:无效的主机名。
6 y5 D( _; v: K! X4 @2 w+ o1043:无效连接。
; t7 D6 k8 I: |) }- W; p1044:数据库用户权限不足,请联系空间商解决。, s# i' u9 Y0 i( p' j8 m
1045:数据库服务器/数据库用户名/数据库名/数据库密码错误,请联系空间商检查帐户。2 k3 x) }1 x# _. t0 w
Quote:) c9 w/ X3 W# i6 G# B, a
方法:确保论坛data目录下的sql_config.php用户名与密码都正确.如果用户忘记了数据库的密码,可以按如下方式进行密码的修改:: ?& i4 b* \. `0 @, g/ W; z0 M% @
如果 MySQL 正在运行,首先停止。' y( Z4 s: R, {6 m
启动 MySQL :bin/safe_mysqld --skip-grant-tables &+ v; O7 D0 w; i& Y: W
就可以不需要密码就进入 MySQL 了。8 X5 V$ _; g3 F( n5 C8 Q
然后就是( i8 X- _4 |& r7 k
>use mysql
, Z2 I' y1 w7 x- m3 ~3 o- A' N>update user set password=password("new_pass") where user="root";* H% T: e7 v3 \0 b8 s' I# j
>flush privileges;- x9 O8 d- ^* k# w
1046:没有选择数据库。
5 r" H' J: P' }2 |1048:字段不能为空。
: Z* x. R2 e5 p9 J2 v/ E3 l" X1049:数据库不存在。6 s) l2 f4 p  ~* Q! U
1050:数据表已存在。  t/ O' M' ^5 f, @# M- D. ^
1051:数据表不存在。$ _; u+ M9 T: U6 T) j
1054:字段不存在,自行建立字段。, a" I. p, T6 G* X* _
1060:字段重复,导致无法插入这个字段。+ d  T: C, Y- ?7 I6 g9 M
1062:字段值重复,入库失败  x; |  d7 ]% v: ]  b, b
Quote:
1 K! c& e  A0 R5 f1.如果出类似主码为"65535"的错误,可以查看相关表的自增字段,将字段值改在就可以) ?, ]& {4 X$ p( ~) {. _
2.确保相关数据表中主码重复的字段是否存在,如果存在删除这条记录
* |, ]7 z1 r/ R/ j2 }, C; _$ z3.备份数据库,修复相关表(注:这种情况比较常见,如pw_posts表,对表进行修复的时候不要忘记备份).  j4 s* E7 N  z( X8 q! x( C
1064:MySQL 不支持错误提示中的编码。
5 h4 G4 {+ {# |1 v% d' h1065:无效的 SQL 语句,SQL 语句为空。
8 P- C( o: l' ], Q, X4 R1067:MySQL 版本为 5,不支持空的默认值。- J5 A" i% c5 o1 B' R
1081:不能建立 Socket 连接。
# d: {3 ~( }* y4 N) T( F7 [1114:数据表已满,不能容纳任何记录。
. Q5 p' W- _* i- R1115:设置的字符集在 MySQL 并没有支持。4 ?" X& l0 W1 o
1116:打开的数据表太多。9 f! u4 B+ X+ B7 O; B& l8 S5 C9 J
1129:数据库出现异常,请重启数据库。
0 i; K* ^3 _% F1130:连接数据库失败,没有连接数据库的权限。- I  p& r8 i' d' h2 E
1133:数据库用户不存在。* f2 s& M. {! V) v' q
1135:可能是内存不足够,请联系空间商解决。$ _, F  ]9 \# k0 N; Z
1141:当前用户无权访问数据库。: d8 Z) d% {7 k2 Z; p
1142:当前用户无权访问数据表。
0 Q; \  O7 ~& F; O  x1143:当前用户无权访问数据表中的字段。" h( x6 V8 e+ L, F: y
1146:数据表缺失,请恢复备份数据
2 D8 W$ H% Z3 Q( u* y, z1147:未定义用户对数据表的访问权限。
7 m2 o8 S  m3 R( a0 X1149:SQL 语句语法错误。
6 z$ p2 C9 ]: b* N; U. c# e1158:网络错误,出现读错误,请检查网络连接状况。
& p7 K4 a9 I. V4 X. d1159:网络错误,读超时,请检查网络连接状况。3 v1 x8 a/ Q* C8 Y; y& K
1160:网络错误,出现写错误,请检查网络连接状况。1 v* N2 _  e. a% r
1161:网络错误,写超时,请检查网络连接状况。
/ U/ F% E7 H0 P2 a# g  Y6 ?6 S1169:字段值重复,更新记录失败。
- Y+ h  F" T2 |. }1177:打开数据表失败。
* c8 ~* x: U, S$ v6 X& f1180:提交事务失败。1 y' i, @' |) G  q1 T2 H) Y" I
1181:回滚事务失败。
2 f( \1 @0 Z# ~1193:不支持字符集限定(SET NAMES)。
$ x; g4 N. H+ \: r) f0 Z1 _% g1203:当前用户和数据库建立的连接已到达数据库的最大连接数,请增大可用的数据库连接数或重启数据库。
  I- f8 J0 Y5 u# q. {/ h1205:加锁超时。
; F# d7 L0 G; M6 e1211:当前用户没有创建用户的权限。
9 [/ C! i0 X; x0 C1216:外键约束检查失败,更新子表记录失败。
0 V' m7 k' |) }) I1217:外键约束检查失败,删除或修改主表记录失败。; V- s" F3 @6 n* \8 |  t
1226:当前用户使用的资源已超过所允许的资源,请重启数据库或重启服务器。
1 Y( I) r& v0 a1227:权限不足,您无权进行此操作。6 c- u$ f" o; U8 R
1235:MySQL版本过低,不具有本功能。9 ]+ C( @  H5 u  J' z. c+ O
1250:客户端不支持服务器要求的认证协议,请考虑升级客户端。- f4 P1 e# L, [* D# b
1251:Client 不能支持 authentication protocol 的要求. S% _$ D6 T8 @3 Q0 @3 \
Client does not support authentication protocol requested by server; consider upgrading MySQL client
4 @) T3 M' T$ k: S0 ]  u# ]2 }Quote:
- x* J  L$ h+ [& W1 M2 l6 Z方法1:mysql> SET PASSWORD FOR$ G/ |4 T5 P* ~8 d1 K( o6 e
-> ' some_user '@' some_host ' = OLD_PASSWORD(' newpwd ');! n+ u2 i5 \1 J) y6 S
结合我们的实际情况,在 MySQL Command Line Client 下运行:
4 s$ V5 l5 `& q# O+ W$ y, fset password for root@localhost = old_password('123456');
* ]. p2 B$ _& b  e方法2:
* C0 s! |# f$ `' T, ?( kmysql> UPDATE mysql.user SET Password = OLD_PASSWORD('newpwd')
  G, \4 w% d( |: A$ e0 [. m-> WHERE Host = 'some_host' AND User = 'some_user';* K8 w2 r" C" N- p1 g# B, ?5 L
mysql> FLUSH PRIVILEGES;0 Q6 c. W8 V0 t2 @
上面红色的部分请按自己实际情况修改。- l9 g, K' O1 f/ p
1267:不合法的混合字符集。/ H7 i7 f  s& k2 V% I
2002:服务器端口不对,请咨询空间商正确的端口。5 `( h9 ]- Q7 i2 i3 R; ]
2003:MySQL 服务没有启动,请启动该服务。9 I( G8 F* z5 Y* R
2008:MySQL client ran out of memory
0 R! e1 C: o3 w7 m0 M, f错误指向了MySQL客户mysql。这个错误的原因很简单,客户没有足够的内存存储全部结果。1 U. L3 q; P1 A* H
2013:远程连接数据库是有时会有这个问题,MySQL 服务器在执行一条 SQL 语句的时候失去了连接造成的。
9 ^6 `4 r7 }9 A2 W+ R+ h8 N% R10048:
' |% ^+ s2 A: z7 i) @" CQuote:
7 E4 V. M6 c. p/ e* ~1 D建议在my.ini文件中修改最大连接数,3 \' \- P- u% z) Q' c0 Q8 G1 {
把 mysql_connect() 方法都改成了 mysql_pconnect() 方法.
. ?; n" G" G- V, ?( {要修改mysql_pconnect(),可以在论坛的data目录的sql_config.php中" ^1 d* _( a- q
$pconnect = 0; //是否持久连接3 h  ^$ ~' i- ]$ r6 ]
修改成$pconnect = 1;' Q/ |+ r% W# J8 ?3 F4 P8 P
开启防刷新,严禁刷新太快.
* A, _0 W4 y3 F, z/ h10055:没有缓存空间可利用
0 ]) m* W  Z) X1 P1 H% `& UQuote:' h. k4 Q! |1 c  m
查看下你的C盘空间是否已经满,清除一些没有用的文件.
. G, y( h7 e: w可以在后台的"论坛核心设置","核心功能设置"里"进程优化"开启,"GZIP 压缩输出"关闭.
$ V/ [4 D6 U4 f% G3 [查找了一下10055(没有缓存空间可利用)出错的原因,分析了my.ini的配制文件,在my.ini中如下:% i' x" k/ x9 j) R6 K2 l
default-storage-engine=INNODB
( f8 w  Y/ b( \0 E' Uinnodb_additional_mem_pool_size=2M
$ e7 X9 ~% D6 L/ }/ cinnodb_flush_log_at_trx_commit=13 y" L$ k/ G: |1 d) E8 ]; s
innodb_log_buffer_size=1M
5 g9 P+ K9 ?& T# v6 u% Uinnodb_buffer_pool_size=10M  t! O9 S  c; s
innodb_log_file_size=10M
3 S) H4 T4 |  ~innodb_thread_concurrency=8
6 c5 O2 K  E" F2 B觉得可以把innodb_buffer_pool_size=10M 加大如100M或是1000M
4 o& |1 Q8 t0 y4 P; @7 e以上是对mysql5的; A0 Q. Y- Y7 p% H. {" X
如果是mysql4可以在my.ini中增加如下:! y! E% p- X: T
#innodb_data_file_path = ibdata1:2000M;ibdata2:2000M
. r0 T& H7 U4 U: x! }  B5 Z" N, D#innodb_data_home_dir = c:ibdata' q7 U/ \* ~$ f9 E  F/ L
#innodb_log_group_home_dir = c:iblogs- _* ^  {# P" x( a% h1 `' ~
#innodb_log_arch_dir = c:iblogs# s/ i4 ]/ \9 o! l& m- n" z) R
#set-variable = innodb_mirrored_log_groups=1
/ C1 W) l/ [9 ~1 f% q  |) F- c#set-variable = innodb_log_files_in_group=3! @6 I* r& h1 A% T1 q  [
#set-variable = innodb_log_file_size=5M
& q) H! Y/ `: V#set-variable = innodb_log_buffer_size=8M( N7 U4 q' F. I3 v( `3 q& S, i
#innodb_flush_log_at_trx_commit=1
9 p( G4 {2 L3 r7 O  ^$ \7 [#innodb_log_archive=0
1 Q4 k  X2 Q6 v! e( k% x. V#set-variable = innodb_buffer_pool_size=16M/ a* ~& l2 c* H# @+ _9 A8 r
#set-variable = innodb_additional_mem_pool_size=2M
: w# O0 Q! H& @( @#set-variable = innodb_file_io_threads=4
% a) x6 F. |: P0 U: ~; W9 _( S#set-variable = innodb_lock_wait_timeout=50/ z# G. q: H% s) b- q
把前面的#去了) q  l. C: ], l  q3 h

* T1 u! o! S. O' r* YQuote:
8 T8 J6 m( ]/ D4 J, {7 C& J启动这台机器上的MySQL服务, c: R$ B) j- l8 j1 Q9 V0 Q/ V; m
如服务启动失败
: g" ^+ a3 W+ J; C) b! x$ U4 Q9 B一定是你的my.ini文件出了差错,- h  t6 T- ~9 t7 q2 V/ ]2 C- V
MySQL服务不能正常启动
" i, i( R( p. |1 I  H5 Z+ R" ~1 A你删除了它后,MySQL就会按其默认配置运行,
% F4 _1 Q' V/ I0 ?- d% A0 x那就没有问题了
! m- ]$ k0 r& A+ H- h
3 g1 X* {2 R% j: F" Z  m

回复|共 14 个

jckie Lv.8 发表于 2014-10-16 20:45:00|美国 | 查看全部
…没我说话的余地…飘走
efiew Lv.15 发表于 2014-10-16 20:46:27|印度 | 查看全部
楼主,你要继续努力啊!你是bbs的希望啊!你是网络文学的希望啊!你是整个网络界的希望文学界的希望啊!你是整个人类的希望啊!你是整个太阳系的希望啊!你是整个异次元空间的希望啊!
pangio Lv.8 发表于 2014-10-16 20:53:58|美国 | 查看全部
呵呵 高兴成什么样了啊!!!
kbcesuo Lv.8 发表于 2014-10-16 20:57:53|江苏 | 查看全部
我也不知道了~~你把我问蒙了 呵呵
oxdbw Lv.8 发表于 2014-10-16 21:36:37|美国 | 查看全部
我率天兵天将 将你打回原形~~~
阴阳小轩 Lv.8 发表于 2015-1-30 20:06:16|英国 | 查看全部
因删贴不及时所产生的任何法律(书法,基本法,劳动法,婚姻法,输入法,国际法,今日说法,与台湾关系法及文中涉及或可能涉及以及未及之法,各地治安管理条例)纠纷或责任本人概不负责。
effoggikeftor 发表于 2015-1-30 20:06:30|美国 | 查看全部
看你快沉底了~~~~~~
爱上空心菜 Lv.7 发表于 2015-1-30 20:07:53|美国 | 查看全部
不为楼主的标题所吸引,也不是被贴子的内容所迷惑。
buingeEvineus 发表于 2015-1-30 20:08:28|俄罗斯 | 查看全部
极品可以说是让你馨香满腹,三日不绝!!古人说的好:想要作文章,先要学做人。由作者的文章我们也可以揣测出作者定是成长在一个汗牛充栋,文化氛围浓厚而且精神面貌积 极向上的幸福家庭里面。在现在这个物欲横流,亲情冷淡的时代,能够在这样的家庭里
tohme 发表于 2017-4-10 21:54:35|Reserved | 查看全部
…没我说话的余地…飘走
gevaemaidovef 发表于 2017-4-10 21:56:03|波兰 | 查看全部
@,@..是什么意思呀?
seazvyt 发表于 2017-4-10 21:56:32|INNA | 查看全部
楼猪.重量级人物阿.
tohme 发表于 2017-4-10 22:01:49|泰国 | 查看全部
原来...发神经是这样的啊...
GoodyFouppy 发表于 2017-4-10 22:02:04|美国 | 查看全部
先踹你一脚再说~~~~~~

回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

得知互动是一个融创意、设计、开发、营销、生活、互联网于一体的专业交流分享平台。
Copyright © 2026 得知互动-专注Ai与站长技术交流社区-Ai交流平台 版权所有 All Rights Reserved. Powered by Discuz! X5.0 鄂ICP备15006301号-5|鄂公网安备 42018502006730号
关灯 在本版发帖 扫一扫添加QQ客服 返回顶部
快速回复 返回顶部 返回列表